[Добавен] Един чудесен дебъгер - EDB.
#1
Може ли да се включи в хранилището програма, за която няма пакет за centOS? Имам предвид отличния дебъгер EDB:

Хранилище на кода в гит-хъб: https://github.com/eteran/edb-debugger
Сайт на проекта със стабилни релизи: http://codef00.com/projects

Аз за мене си го компилирам от сорса, но е голяма играчка.
Отговори
#2
Никакви ядове, възможно най скоро ще го добавим стига това да е възможно.
Може да следиш темата за напредък.

Поздрави!
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#3
Експресно ще е Big Grin
Отговори
#4
Съжалявам, не знам до колко ще ви свърши работа, но за сега ще трябва да се задоволиш със версия 0.9.18 , тъй като новата версия (0.9.20) се издъни, но утре ще пробваме на ново, и евентуално ще има актуализация.

Ето пакета - > [1] http://stotinkaos.net/stotinkaOS/repo/6/...w/edb.html

За сега за x86_64 бита версия, утре ще се тества къде греши новата версия, и ще качим и 32 бита.

Инсталирай:

Код:
# yum clean metadata
# yum install edb
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#5
(15-05-2015, 23:50)ivo написа: Съжалявам, не знам до колко ще ви свърши работа, но за сега ще трябва да се задоволиш със версия 0.9.18 , тъй като новата версия (0.9.20) се издъни, но утре ще пробваме на ново, и евентуално ще има актуализация.

По принцип, 0.9.18 ще свърши работа. Аз си компилирах тази от гитхъб - още преди няколко дни. Но нали ще пишем статия за асемблер и затова ми трябва в хранилището. Иначе статията ще се превърне в роман техно-трилър "Да компилираш edb!". Wink

Съжалявам, че не го написах, обаче снощи много ми се спеше и забравих. Sleepy
При 0.9.20 и версиите от гитхъб има някакъв проблем при компилацията, който се оправя, като се коментира ред 158 на "src/main.cpp".

Решението го намерих в stackoverflow, Нямам си на идея за какво служи въпросния ред, нито пък авторът как го компилира.

Благодаря за пакета!

Поздрави
Отговори
#6
(16-05-2015, 07:33)johnfound написа: Съжалявам, че не го написах, обаче снощи много ми се спеше и забравих.  Sleepy
При 0.9.20 и версиите от гитхъб има някакъв проблем при компилацията, който се оправя, като се коментира ред 158 на "src/main.cpp".

Решението го намерих в stackoverflow, Нямам си на идея за какво служи въпросния ред, нито пък авторът как го компилира.

Благодаря за пакета!

Поздрави

Няма проблеми, така или иначе трябваше да се изпробва. За сега ще се задоволим със тази версия, пакета който направих, е ребуилднат от Fedora Rawhide (23), ето тук, както казах пробвах да актуализирам до нова версия но не се получи, и ще трябва да се разгледа по добре. Относно тази линия, трябва да се прегледа, и евентуално да се пробва със създаване на кръпка (.patch) и да се ребуилдне със нея пакета.

За сега ще е това, след малко ще се качи и пакета за 32 бита машини.

Ако имаш други предложения за пакети, ще се радваме ги чуем.

Поздрави!
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#7
Махнах 0.9.20 и инсталирах 0.9.18, обаче не се стартира. От конзолата дава:
Код:
Starting edb version: 0.9.18
Please Report Bugs & Requests At: http://bugs.codef00.com/
Segmentation fault

При вас работи ли?
Отговори
#8
При мене със 32 битовата версия всичко е шест, и се стартира нормално. Ако някой иска да помогне да изпробва 64 битовата версия и да каже.
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#9
Току що качих 64 бит. версия и при мен се стартира.

[Изображение: edb.png]
Отговори
#10
Оправенo. Трябваше просто да изтрия конфигурационния файл, останал от v0.9.21. Той обаче се намира на неочевидно място: "~/.config/codef00.com"
Отговори




Потребители разглеждащи темата: 1 гост(и)