[РЕШЕН] Инсталация на нов лаптоп Lenovo 320-15ISK
#11
Системата постоянно се рестартираше. Сега го преинсталирах но пак при актуализация ми дава грешка този път за GRUB2:

Грешки в удовлетворяването на зависимости:

Пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64 (base)
Изисква: grub2-common = 1:2.02-0.64.el7.centos
Наличен: 1:grub2-common-2.02-0.64.el7.centos.noarch (base)
grub2-common = 1:2.02-0.64.el7.centos
Инсталиране: 1:grub2-common-2.02-0.65.el7.centos.2.noarch (updates)
grub2-common = 1:2.02-0.65.el7.centos.2

Ако има значение сложих CINNAMON среда:
Отговори
#12
(30-11-2017, 16:51)iliyan71 написа: Системата постоянно се рестартираше. Сега го преинсталирах но пак при актуализация ми дава грешка този път за GRUB2:

Грешки в удовлетворяването на зависимости:

Пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64 (base)
   Изисква: grub2-common = 1:2.02-0.64.el7.centos
   Наличен: 1:grub2-common-2.02-0.64.el7.centos.noarch (base)
       grub2-common = 1:2.02-0.64.el7.centos
   Инсталиране: 1:grub2-common-2.02-0.65.el7.centos.2.noarch (updates)
       grub2-common = 1:2.02-0.65.el7.centos.2

Ако има значение сложих CINNAMON среда:

Не мога да се ориентирам за пакетите, мисля това не е цялото съобщение.

Cinnamon работи, но или трябва да я използваш на 7.3, или да обновиш до 7.4 и едновременно да обновиш и самия Cinnamon.
Стария Cinnamon няма да работи в средата на 7.4.

Ще се улесниш, ако първо инсталираш от GNOME или XFCE образа, обновиш системата и след това инсталираш Cinnamon средата. Тогава няма вероятност да ти забие и да останеш без Desktop, ако не успееш да приложиш всички ъпдейти наведнъж.
Отговори
#13
(01-12-2017, 14:47)fortify написа: Не мога да се ориентирам за пакетите, мисля това не е цялото съобщение.

Cinnamon работи, но или трябва да я използваш на 7.3, или да обновиш до 7.4 и едновременно да обновиш и самия Cinnamon.
Стария Cinnamon няма да работи в средата на 7.4.

Ще се улесниш, ако първо инсталираш от GNOME или XFCE образа, обновиш системата и след това инсталираш Cinnamon средата. Тогава няма вероятност да ти забие и да останеш без Desktop, ако не успееш да приложиш всички ъпдейти наведнъж.

Ок инсталирах XFCE след рестарта ми изписа на екрана това преди да зареди СтотинкаОс:

[    1.655654]  EFI: Problem loading in-kernel x.509 certificate (-129)
[    1.655684]  EFI: Problem loading in-kernel x.509 certificate (-65)
[    5.073084]  sd 2:0:0:0: [sdb] No Caching mode page found
[    5.073182]  sd 2:0:0:0: [sdb] Assuming drive cache write through

А това е целия рапорт от актуализацията която завърши с грешката която дадох в предния пост:

.txt   raport.txt (Размер: 163.96 KB / Сваляния: 3)
Отговори
#14
(01-12-2017, 17:09)iliyan71 написа: Ок инсталирах XFCE след рестарта ми изписа на екрана това преди да зареди СтотинкаОс:

[    1.655654]  EFI: Problem loading in-kernel x.509 certificate (-129)
[    1.655684]  EFI: Problem loading in-kernel x.509 certificate (-65)
[    5.073084]  sd 2:0:0:0: [sdb] No Caching mode page found
[    5.073182]  sd 2:0:0:0: [sdb] Assuming drive cache write through

Първото предупреждение "Problem loading in-kernel x.509 certificate" не изглежда да е нещо съществено. Второто отбелязва, че дисковият кеш може да не работи оптимално. Не съм го срещал и не знам какво точно означава. Много вероятно и двете да се разкарат с обновяването на ядрото.

Цитат:А това е целия рапорт от актуализацията която завърши с грешката която дадох в предния пост:

Грешката е интересна, не разбирам какво точно не му харесва. Но бих опитал да обновя първо въпросните пакети:
Код:
sudo yum update grub2-common
sudo yum update grub2-tools-efi

Очаквам след това да можеш да минеш нататък. Има вероятност да изникнат още някои, описани тук:
https://www.stotinkaos.net/forums/thread...ml#pid9740

Ако има още проблеми сме насреща.
Отговори
#15
При първата команда ми даде че нямам инсталиран grub2-common инсталирах го след това упдейтнах.
При втората ми даде грешка:
yum update grub2-tools-efi
Заредени плъгини: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* StotinkaOS-Base: stotinkaos.net
* StotinkaOS-Wine: stotinkaos.net
* base: mirrors.netix.net
* elrepo: mirrors.netix.net
* epel: mirror.t-home.mk
* extras: mirrors.netix.net
* updates: mirrors.netix.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет grub2-tools.x86_64 1:2.02-0.44.el7.centos ще е излязъл от употреба
--> Обработвам зависимости: grub2-tools = 1:2.02-0.44.el7.centos за пакет: 1:grub2-2.02-0.44.el7.centos.x86_64
--> Обработвам зависимости: grub2-tools = 1:2.02-0.44.el7.centos за пакет: 1:grub2-efi-2.02-0.44.el7.centos.x86_64
---> Пакет grub2-tools.x86_64 1:2.02-0.44.el7.centos ще е обновен
---> Пакет grub2-tools.x86_64 1:2.02-0.65.el7.centos.2 ще е заместващ
--> Обработвам зависимости: grub2-tools-minimal = 1:2.02-0.65.el7.centos.2 за пакет: 1:grub2-tools-2.02-0.65.el7.centos.2.x86_64
---> Пакет grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos ще е заместващ
--> Обработвам зависимости: grub2-common = 1:2.02-0.64.el7.centos за пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64
--> Извършвам проверка на транзакцията
---> Пакет grub2.x86_64 1:2.02-0.44.el7.centos ще е обновен
---> Пакет grub2.x86_64 1:2.02-0.44.el7.centos ще е излязъл от употреба
---> Пакет grub2.x86_64 1:2.02-0.65.el7.centos.2 ще е заместващ
--> Обработвам зависимости: grub2-pc = 1:2.02-0.65.el7.centos.2 за пакет: 1:grub2-2.02-0.65.el7.centos.2.x86_64
---> Пакет grub2-efi.x86_64 1:2.02-0.44.el7.centos ще е излязъл от употреба
---> Пакет grub2-efi-x64.x86_64 1:2.02-0.65.el7.centos.2 ще е заместващ
--> Обработвам зависимости: grub2-tools-extra = 1:2.02-0.65.el7.centos.2 за пакет: 1:grub2-efi-x64-2.02-0.65.el7.centos.2.x86_64
---> Пакет grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos ще е заместващ
--> Обработвам зависимости: grub2-common = 1:2.02-0.64.el7.centos за пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64
---> Пакет grub2-tools-minimal.x86_64 1:2.02-0.65.el7.centos.2 ще е заместващ
--> Извършвам проверка на транзакцията
---> Пакет grub2-pc.x86_64 1:2.02-0.65.el7.centos.2 ще е инсталиран
--> Обработвам зависимости: grub2-pc-modules = 1:2.02-0.65.el7.centos.2 за пакет: 1:grub2-pc-2.02-0.65.el7.centos.2.x86_64
---> Пакет grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos ще е заместващ
--> Обработвам зависимости: grub2-common = 1:2.02-0.64.el7.centos за пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64
---> Пакет grub2-tools-extra.x86_64 1:2.02-0.65.el7.centos.2 ще е заместващ
--> Извършвам проверка на транзакцията
---> Пакет grub2-pc-modules.noarch 1:2.02-0.65.el7.centos.2 ще е инсталиран
---> Пакет grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos ще е заместващ
--> Обработвам зависимости: grub2-common = 1:2.02-0.64.el7.centos за пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64
Removing grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos - u due to obsoletes from grub2-tools.x86_64 1:2.02-0.65.el7.centos.2 - u
--> Рестартирам определянето на зависимости с новите промени.
--> Извършвам проверка на транзакцията
---> Пакет grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos ще е заместващ
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64 (base)
Изисква: grub2-common = 1:2.02-0.64.el7.centos
Инсталиран: 1:grub2-common-2.02-0.65.el7.centos.2.noarch (@updates)
grub2-common = 1:2.02-0.65.el7.centos.2
Наличен: 1:grub2-common-2.02-0.64.el7.centos.noarch (base)
grub2-common = 1:2.02-0.64.el7.centos
Може да пробвате с --skip-broken за да заобиколите проблема
Може да пробвате като стартирате: rpm -Va --nofiles --nodigest
Отговори
#16
А защо не пробваш ето така:

Код:
yum -x grub2-tools-efi update
Май разбрах къде се крие грешката.
Код:
Грешка: Пакет: 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64 (base)
Изисква: grub2-common = 1:2.02-0.64.el7.centos

Код:
Инсталиран: 1:grub2-common-2.02-0.65.el7.centos.2.noarch (@updates)

Код:
Наличен: 1:grub2-common-2.02-0.64.el7.centos.noarch (base)

Може ли да направиш даунгреид на grub2-common-2.02-0.65.el7.centos.2.noarch
след това да изключиш хранилището @update и да ъпдейтнеш grub2-common = 1:2.02-0.64.el7.centos това има налично в @base

grub2-tools-efi-2.02-0.64.el7.centos.x86_64 иска по стара версия на grub2-common ,,,,,,,64.el7.centos
[Изображение: Tux-sos_new_logo.png]                                                                                                                                                                                                                                              
Отговори
#17
(01-12-2017, 20:44)Стилиян Любчев написа: А защо не пробваш ето така:

Код:
yum -x grub2-tools-efi update

Да се изключи проблемният пакет от ъпдейта е хитра идея. Особено в случая няма да навреди, защото и стария GRUB ще стартира без проблеми.

Аз дори бих го махнал, след това цялостно обновяване. Накрая може да се инсталира отново.
Обаче трябва да се внимава, да не повлече и други пакети с премахването. Конкретно за този съм доста убеден, че не е важен и нищо не зависи от него. Просто помощни инструменти за манипулация на EFI.

Код:
sudo yum remove grub2-tools-efi

Аха, опитах да инсталирам въпросният пакет при мен:

Код:
2:00:30 : YUM: Package 1:grub2-tools-efi-2.02-0.64.el7.centos.x86_64 is obsoleted by 1:grub2-tools-2.02-0.65.el7.centos.2.x86_64 which is already installed

Така че grub2-tools-efi следва да се деинсталира, защото функционалността е преместена в grub2-tools.
Отговори
#18
Успях успешно да актуализирам системата. С кода на @Стилиян Любчев и след това на @exwol стана. Сега се мъча с да инсталирам новото ядро за да имам тъчпад.

Инсталирах новото ядро но при рестарт и зареждане на него ми дава грашка:

еrror: /vmlinuz-4.14.3-1.al7.alrepo.x86_64 has invalid signature.
error: you need to load the kernel first.
Press any key to continue...

След натискане на клавиш ме връща в основното меню за избор на ядро.
Отговори
#19
(01-12-2017, 22:03)iliyan71 написа: Успях успешно да актуализирам системата. С кода на @Стилиян Любчев и след това на @exwol стана. Сега се мъча с да инсталирам новото ядро за да имам тъчпад.

Инсталирах новото ядро но при рестарт и зареждане на него ми дава грашка:

еrror: /vmlinuz-4.14.3-1.al7.alrepo.x86_64 has invalid signature.
error: you need to load the kernel first.
Press any key to continue...

След натискане на клавиш ме връща в основното меню за избор на ядро.


Опитай да заредиш по-старото ядро и дай изхода от командата:
Код:
cat /etc/stotinkaos-release
Отговори
#20
Това е изхода от командата:

[svetla@svetla ~]$ cat /etc/stotinkaos-release
StotinkaOS Linux release 7.4.1708 (Algara)
[svetla@svetla ~]$
Отговори




Потребители разглеждащи темата: 1 гост(и)