Преминаване от StotinkaOS на CentOS
#31
[Iliyan@iliyan ~]$ sudo rpm -uvh http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
[sudo] password for Iliyan:
rpm: -uvh: unknown option

В бързината навярно си добавил буква но не съм сигурен.
Отговори
#32
Редактирах командата , моя грешка .
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#33
[Iliyan@iliyan ~]$ sudo rpm -Uvh http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
[sudo] password for Iliyan:
Retrieving http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
error: Failed dependencies:
nss(x86-64)
Отговори
#34
Пробвай с yum

Код:
sudo yum install http://mirror.centos.org/centos/7/os/x86_64/Packages/nss-3.36.0-7.el7_5.x86_64.rpm
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#35
[Iliyan@iliyan ~]$ sudo yum install http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
Заредени плъгини: fastestmirror, langpacks
nss-3.36.0-7.el7_5.x86_64.rpm | 835 kB 00:00:00
Проверявам /var/tmp/yum-root-LSjZaQ/nss-3.36.0-7.el7_5.x86_64.rpm: nss-3.36.0-7.el7_5.x86_64
Маркирам /var/tmp/yum-root-LSjZaQ/nss-3.36.0-7.el7_5.x86_64.rpm като обновление към nss-3.36.0-5.el7_5.x86_64
Маркирам /var/tmp/yum-root-LSjZaQ/nss-3.36.0-7.el7_5.x86_64.rpm като обновление към nss-3.36.0-5.el7_5.i686
/var/tmp/yum-root-LSjZaQ/nss-3.36.0-7.el7_5.x86_64.rpm: не обнови инсталиран пакет.
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет nss.x86_64 0:3.36.0-5.el7_5 ще е обновен
--> Обработвам зависимости: nss(x86-64) = 3.36.0-5.el7_5 за пакет: nss-tools-3.36.0-5.el7_5.x86_64
Loading mirror speeds from cached hostfile
* base: mirrors.netix.net
* elrepo: mirrors.netix.net
* epel: mirrors.netix.net
* extras: mirrors.netix.net
* updates: mirrors.netix.net
---> Пакет nss.x86_64 0:3.36.0-7.el7_5 ще е обновление
---> Пакет nss.x86_64 0:3.36.0-7.el7_5 ще е обновен
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Пакет: nss-tools-3.36.0-5.el7_5.x86_64 (@updates)
Изисква: nss(x86-64) = 3.36.0-5.el7_5
Премахване: nss-3.36.0-5.el7_5.x86_64 (@updates)
nss(x86-64) = 3.36.0-5.el7_5
Обновен от: nss-3.36.0-7.el7_5.x86_64 (/nss-3.36.0-7.el7_5.x86_64)
nss(x86-64) = 3.36.0-7.el7_5
Може да пробвате с --skip-broken за да заобиколите проблема
** Намерени 23 предварително съществуващи rpmdb проблема, 'yum check' показа следното:
dconf-0.26.0-3.el7_5.1.x86_64 се дублира с dconf-0.26.0-2.el7.x86_64
firefox-60.2.1-1.el7.centos.x86_64 се дублира с firefox-60.2.0-1.el7.centos.x86_64
firewall-config-0.4.4.4-15.el7_5.noarch се дублира с firewall-config-0.4.4.4-14.el7.noarch
firewalld-0.4.4.4-15.el7_5.noarch се дублира с firewalld-0.4.4.4-14.el7.noarch
firewalld-filesystem-0.4.4.4-15.el7_5.noarch се дублира с firewalld-filesystem-0.4.4.4-14.el7.noarch
initscripts-9.49.41-1.el7_5.2.x86_64 се дублира с initscripts-9.49.41-1.el7_5.1.x86_64
kernel-headers-3.10.0-862.14.4.el7.x86_64 се дублира с kernel-headers-3.10.0-862.11.6.el7.x86_64
kernel-tools-3.10.0-862.14.4.el7.x86_64 се дублира с kernel-tools-3.10.0-862.11.6.el7.x86_64
kernel-tools-libs-3.10.0-862.14.4.el7.x86_64 се дублира с kernel-tools-libs-3.10.0-862.11.6.el7.x86_64
kexec-tools-2.0.15-13.el7_5.2.x86_64 се дублира с kexec-tools-2.0.15-13.el7_5.1.x86_64
libgudev1-219-57.el7_5.3.x86_64 се дублира с libgudev1-219-57.el7_5.1.x86_64
libsss_idmap-1.16.0-19.el7_5.8.x86_64 се дублира с libsss_idmap-1.16.0-19.el7_5.5.x86_64
libsss_nss_idmap-1.16.0-19.el7_5.8.x86_64 се дублира с libsss_nss_idmap-1.16.0-19.el7_5.5.x86_64
mutter-3.26.2-17.el7_5.x86_64 се дублира с mutter-3.26.2-15.el7_5.x86_64
nss-3.36.0-7.el7_5.x86_64 се дублира с nss-3.36.0-5.el7_5.x86_64
nss-sysinit-3.36.0-7.el7_5.x86_64 се дублира с nss-sysinit-3.36.0-5.el7_5.x86_64
nss-tools-3.36.0-7.el7_5.x86_64 се дублира с nss-tools-3.36.0-5.el7_5.x86_64
python-firewall-0.4.4.4-15.el7_5.noarch се дублира с python-firewall-0.4.4.4-14.el7.noarch
sssd-client-1.16.0-19.el7_5.8.x86_64 се дублира с sssd-client-1.16.0-19.el7_5.5.x86_64
systemd-219-57.el7_5.3.x86_64 се дублира с systemd-219-57.el7_5.1.x86_64
systemd-libs-219-57.el7_5.3.x86_64 се дублира с systemd-libs-219-57.el7_5.1.x86_64
systemd-python-219-57.el7_5.3.x86_64 се дублира с systemd-python-219-57.el7_5.1.x86_64
systemd-sysv-219-57.el7_5.3.x86_64 се дублира с systemd-sysv-219-57.el7_5.1.x86_64
[Iliyan@iliyan ~]$
Отговори
#36
Код:
sudo yum install http://mirror.centos.org/centos/7/os/x86_64/Packages/nss-3.36.0-7.el7_5.x86_64.rpm http://mirror.centos.org/centos/7/os/x86_64/Packages/nss-tools-3.36.0-7.el7_5.x86_64.rpm
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#37
---> Пакет nss-tools.x86_64 0:3.36.0-7.el7_5 ще е обновен
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for nss which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of nss of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude nss.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of nss installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of nss installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: nss-3.36.0-7.el7_5.x86_64 != nss-3.36.0-5.el7_5.i686
[Iliyan@iliyan ~]$
Отговори
#38
Код:
wget http://mirror.centos.org/centos/7/os/x86_64/Packages/nss-3.36.0-7.el7_5.x86_64.rpm
wget http://mirror.centos.org/centos/7/os/x86_64/Packages/nss-tools-3.36.0-7.el7_5.x86_64.rpm
sudo yum install nss-3.36.0-7.el7_5.x86_64.rpm nss-tools-3.36.0-7.el7_5.x86_64.rpm
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#39
---> Пакет nss-tools.x86_64 0:3.36.0-7.el7_5 ще е обновен
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for nss which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of nss of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude nss.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of nss installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of nss installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: nss-3.36.0-7.el7_5.x86_64 != nss-3.36.0-5.el7_5.i686
[Iliyan@iliyan ~]$

пак същото
Отговори
#40
Не може да е пак същото,

Свали 2та пакета, и се увери че инсталираш 2та пакета наведнъж иначе ще даде грешка .
Моля, копирай не само изхода, а и командата която изпълняваш , понеже не знам какво точно си изпълнил дали ти грешиш или аз .
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори




Потребители разглеждащи темата: 1 гост(и)