Преминаване от StotinkaOS на CentOS
#41
[Iliyan@iliyan ~]$ wget http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
--2018-12-15 21:35:10-- http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
Преобразувам mirror.centos.org (mirror.centos.org)... 62.141.54.220, 2a02:2658:1056:0:222:19ff:fed6:7c99
Connecting to mirror.centos.org (mirror.centos.org)|62.141.54.220|:80... успешно свързване.
HTTP изпратено искане, чакам отговор... 200 OK
Дължина: 854864 (835K) [application/x-rpm]
Saving to: ‘nss-3.36.0-7.el7_5.x86_64.rpm’

100%[====================================================>] 854.864 2,37MB/s in 0,3s

2018-12-15 21:35:10 (2,37 MB/s) - ‘nss-3.36.0-7.el7_5.x86_64.rpm’ saved [854864/854864]

[Iliyan@iliyan ~]$ wget http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
--2018-12-15 21:35:22-- http://mirror.centos.org/centos/7/os/x86...x86_64.rpm
Преобразувам mirror.centos.org (mirror.centos.org)... 62.141.54.220, 2a02:2658:1056:0:222:19ff:fed6:7c99
Connecting to mirror.centos.org (mirror.centos.org)|62.141.54.220|:80... успешно свързване.
HTTP изпратено искане, чакам отговор... 200 OK
Дължина: 526912 (515K) [application/x-rpm]
Saving to: ‘nss-tools-3.36.0-7.el7_5.x86_64.rpm’

100%[====================================================>] 526.912 2,00MB/s in 0,3s

2018-12-15 21:35:23 (2,00 MB/s) - ‘nss-tools-3.36.0-7.el7_5.x86_64.rpm’ saved [526912/526912]

[Iliyan@iliyan ~]$ sudo yum install nss-3.36.0-7.el7_5.x86_64.rpm nss-tools-3.36.0-7.el7_5.x86_64.rpm
Заредени плъгини: fastestmirror, langpacks
Проверявам nss-3.36.0-7.el7_5.x86_64.rpm: nss-3.36.0-7.el7_5.x86_64
Маркирам nss-3.36.0-7.el7_5.x86_64.rpm като обновление към nss-3.36.0-5.el7_5.x86_64
Маркирам nss-3.36.0-7.el7_5.x86_64.rpm като обновление към nss-3.36.0-5.el7_5.i686
nss-3.36.0-7.el7_5.x86_64.rpm: не обнови инсталиран пакет.
Проверявам nss-tools-3.36.0-7.el7_5.x86_64.rpm: nss-tools-3.36.0-7.el7_5.x86_64
Маркирам nss-tools-3.36.0-7.el7_5.x86_64.rpm като обновление към nss-tools-3.36.0-5.el7_5.x86_64
nss-tools-3.36.0-7.el7_5.x86_64.rpm: не обнови инсталиран пакет.
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет nss.x86_64 0:3.36.0-5.el7_5 ще е обновен
---> Пакет nss.x86_64 0:3.36.0-7.el7_5 ще е обновление
---> Пакет nss.x86_64 0:3.36.0-7.el7_5 ще е обновен
---> Пакет nss-tools.x86_64 0:3.36.0-5.el7_5 ще е обновен
---> Пакет nss-tools.x86_64 0:3.36.0-7.el7_5 ще е обновление
---> Пакет nss-tools.x86_64 0:3.36.0-7.el7_5 ще е обновен
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for nss which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of nss of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude nss.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of nss installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of nss installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: nss-3.36.0-7.el7_5.x86_64 != nss-3.36.0-5.el7_5.i686
[Iliyan@iliyan ~]$

Заповядай
Отговори
#42
Благодаря, значи може ли да пробваш това .

sudo yum distro-sync
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#43
Всичко мина добре накрая ми даде това:

Transaction check error:
file /usr/lib64/gstreamer-1.0/libgstmpg123.so from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-bad-freeworld-1.0.6-1.el7.centos.sos.x86_64
file /usr/lib64/gstreamer-1.0/libgstcdio.so from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/lib64/gstreamer-1.0/libgstdvdread.so from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/lib64/gstreamer-1.0/libgstxingmux.so from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/af/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/az/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/bg/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/ca/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/cs/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/da/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/de/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/el/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/en_GB/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/eo/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/es/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/eu/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/fi/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/fr/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/gl/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/hr/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/hu/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/id/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/it/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/ja/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/lt/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/lv/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/ms/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/mt/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/nb/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/nl/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/or/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/pl/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/pt_BR/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/ro/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/ru/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/sk/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/sl/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/sq/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/sr/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/sv/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/tr/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/uk/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/vi/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
file /usr/share/locale/zh_CN/LC_MESSAGES/gst-plugins-ugly-1.0.mo from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64

Обобщение на грешките
---------------------
Отговори
#44
sudo yum remove gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64

sudo yum install gstreamer1-plugins-ugly-free
sudo yum update

Цялата система ти е омазана, не си правил доста време актуализации .
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#45
Това е изхода от командите:

[Iliyan@iliyan ~]$ sudo yum remove gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64
[sudo] password for Iliyan:
Заредени плъгини: fastestmirror, langpacks
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет gstreamer1-plugins-ugly.x86_64 0:1.0.6-2.el7.centos.sos ще е изтрит
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies

Зависимостите са удовлетворени

========================================================================================================================
Package Архитектура Версия Хранилище Обем
========================================================================================================================
Премахване:
gstreamer1-plugins-ugly x86_64 1.0.6-2.el7.centos.sos @stotinkaos/$releasever 730 k

Обобщение на транзакцията
========================================================================================================================
Премахни 1 Пакет

Инсталиран обем: 730 k
Така добре ли е [y/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Внимание: RPMDB е променена извън yum.
** Намерени 23 предварително съществуващи rpmdb проблема, 'yum check' показа следното:
dconf-0.26.0-3.el7_5.1.x86_64 се дублира с dconf-0.26.0-2.el7.x86_64
firefox-60.2.1-1.el7.centos.x86_64 се дублира с firefox-60.2.0-1.el7.centos.x86_64
firewall-config-0.4.4.4-15.el7_5.noarch се дублира с firewall-config-0.4.4.4-14.el7.noarch
firewalld-0.4.4.4-15.el7_5.noarch се дублира с firewalld-0.4.4.4-14.el7.noarch
firewalld-filesystem-0.4.4.4-15.el7_5.noarch се дублира с firewalld-filesystem-0.4.4.4-14.el7.noarch
initscripts-9.49.41-1.el7_5.2.x86_64 се дублира с initscripts-9.49.41-1.el7_5.1.x86_64
kernel-headers-3.10.0-862.14.4.el7.x86_64 се дублира с kernel-headers-3.10.0-862.11.6.el7.x86_64
kernel-tools-3.10.0-862.14.4.el7.x86_64 се дублира с kernel-tools-3.10.0-862.11.6.el7.x86_64
kernel-tools-libs-3.10.0-862.14.4.el7.x86_64 се дублира с kernel-tools-libs-3.10.0-862.11.6.el7.x86_64
kexec-tools-2.0.15-13.el7_5.2.x86_64 се дублира с kexec-tools-2.0.15-13.el7_5.1.x86_64
libgudev1-219-57.el7_5.3.x86_64 се дублира с libgudev1-219-57.el7_5.1.x86_64
libsss_idmap-1.16.0-19.el7_5.8.x86_64 се дублира с libsss_idmap-1.16.0-19.el7_5.5.x86_64
libsss_nss_idmap-1.16.0-19.el7_5.8.x86_64 се дублира с libsss_nss_idmap-1.16.0-19.el7_5.5.x86_64
mutter-3.26.2-17.el7_5.x86_64 се дублира с mutter-3.26.2-15.el7_5.x86_64
nss-3.36.0-7.el7_5.x86_64 се дублира с nss-3.36.0-5.el7_5.x86_64
nss-sysinit-3.36.0-7.el7_5.x86_64 се дублира с nss-sysinit-3.36.0-5.el7_5.x86_64
nss-tools-3.36.0-7.el7_5.x86_64 се дублира с nss-tools-3.36.0-5.el7_5.x86_64
python-firewall-0.4.4.4-15.el7_5.noarch се дублира с python-firewall-0.4.4.4-14.el7.noarch
sssd-client-1.16.0-19.el7_5.8.x86_64 се дублира с sssd-client-1.16.0-19.el7_5.5.x86_64
systemd-219-57.el7_5.3.x86_64 се дублира с systemd-219-57.el7_5.1.x86_64
systemd-libs-219-57.el7_5.3.x86_64 се дублира с systemd-libs-219-57.el7_5.1.x86_64
systemd-python-219-57.el7_5.3.x86_64 се дублира с systemd-python-219-57.el7_5.1.x86_64
systemd-sysv-219-57.el7_5.3.x86_64 се дублира с systemd-sysv-219-57.el7_5.1.x86_64
Изтриване : gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64 1/1
Проверка : gstreamer1-plugins-ugly-1.0.6-2.el7.centos.sos.x86_64 1/1

Премахнат:
gstreamer1-plugins-ugly.x86_64 0:1.0.6-2.el7.centos.sos

Завърших!
[Iliyan@iliyan ~]$ sudo yum install gstreamer1-plugins-ugly-free
Заредени плъгини: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirrors.netix.net
* elrepo: mirrors.netix.net
* epel: mirrors.uni-ruse.bg
* extras: mirrors.netix.net
* updates: mirrors.netix.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет gstreamer1-plugins-ugly-free.x86_64 0:1.10.4-3.el7 ще е инсталиран
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies

Зависимостите са удовлетворени

========================================================================================================================
Package Архитектура Версия Хранилище Обем
========================================================================================================================
Инсталиране:
gstreamer1-plugins-ugly-free x86_64 1.10.4-3.el7 base 80 k

Обобщение на транзакцията
========================================================================================================================
Инсталирай 1 Пакет

Общ обем: 80 k
Инсталиран обем: 224 k
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
file /usr/lib64/gstreamer-1.0/libgstmpg123.so from install of gstreamer1-plugins-ugly-free-1.10.4-3.el7.x86_64 conflicts with file from package gstreamer1-plugins-bad-freeworld-1.0.6-1.el7.centos.sos.x86_64

Обобщение на грешките
---------------------

[Iliyan@iliyan ~]$ sudo yum update

След тази команда накрая изписа :
---> Пакет libmx.x86_64 0:1.4.7-10.el7 ще е изтрит
---> Пакет libtxc_dxtn.i686 1:1.0.1-1.gitef072983.el7 ще е изтрит
--> Завърших определянето на зависимости
Грешка: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for nss which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of nss of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude nss.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of nss installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of nss installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: nss-3.36.0-7.el7_5.i686 != nss-3.36.0-5.el7_5.x86_64
[Iliyan@iliyan ~]$
Отговори
#46
sudo yum remove gstreamer1-plugins-bad-freeworld
sudo yum install gstreamer1-plugins-ugly-free
sudo yum distro-sync
sudo yum update
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#47
Първите три команди минаха без проблеми,

[Iliyan@iliyan ~]$ sudo yum update
[sudo] password for Iliyan:
Заредени плъгини: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirrors.netix.net
* elrepo: mirrors.netix.net
* epel: mirrors.uni-ruse.bg
* extras: mirrors.netix.net
* updates: mirrors.netix.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет bpftool.x86_64 0:3.10.0-957.1.3.el7 ще е инсталиран
---> Пакет google-noto-emoji-fonts.noarch 0:20180508-4.el7 ще е инсталиран
---> Пакет nss.i686 0:3.36.0-5.el7_5 ще е обновен
---> Пакет nss.i686 0:3.36.0-7.el7_5 ще е обновление
---> Пакет spice-streaming-agent.x86_64 0:0.2-3.el7 ще е инсталиран
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for nss which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of nss of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude nss.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of nss installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of nss installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: nss-3.36.0-7.el7_5.i686 != nss-3.36.0-5.el7_5.x86_64
[Iliyan@iliyan ~]$
Отговори
#48
sudo yum downgrade nss.i686
sudo yum update

Ако и така не стане ще пробваме по хард метод пък дано не оплескаме нещо .
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#49
[Iliyan@iliyan ~]$ sudo yum downgrade nss.i686
[sudo] password for Iliyan:
Заредени плъгини: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirrors.netix.net
* elrepo: mirrors.netix.net
* epel: mirrors.uni-ruse.bg
* extras: mirrors.netix.net
* updates: mirrors.netix.net
Налично е само надграждане на пакет: nss-3.36.0-7.el7_5.i686
Нищо за правене
[Iliyan@iliyan ~]$ sudo yum update
Заредени плъгини: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirrors.netix.net
* elrepo: mirrors.netix.net
* epel: mirrors.uni-ruse.bg
* extras: mirrors.netix.net
* updates: mirrors.netix.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет bpftool.x86_64 0:3.10.0-957.1.3.el7 ще е инсталиран
---> Пакет google-noto-emoji-fonts.noarch 0:20180508-4.el7 ще е инсталиран
---> Пакет nss.i686 0:3.36.0-5.el7_5 ще е обновен
---> Пакет nss.i686 0:3.36.0-7.el7_5 ще е обновление
---> Пакет spice-streaming-agent.x86_64 0:0.2-3.el7 ще е инсталиран
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for nss which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of nss of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude nss.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of nss installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of nss installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: nss-3.36.0-7.el7_5.i686 != nss-3.36.0-5.el7_5.x86_64
[Iliyan@iliyan ~]$
Отговори
#50
sudo nano /etc/yum.conf

Постави следното запази файла .

exclude= *.i686

После

sudo yum update

Ако и това не стана ще трием
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори




Потребители разглеждащи темата: 1 гост(и)